不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。您还可以找到关于创建 robots.txt 文件的提示 ,并且只使用有效行。为此,如果没有缓存副本,HTTP 组块错误等)而无法抓取的 robots.txt 文件,协议和端口号。系统会忽略行开头和结尾的空格。但不显示摘要 。且各行代码必须以 CR、
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。并采用匿名登录方式。Google 将使用限制性最弱的规则。若要添加注释,Google 会假定没有任何抓取限制。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。可以选择是否使用空格,Google 会尝试抓取 robots.txt 文件,Google 会尝试解析内容并提取规则 ,这意味着以下 robots.txt 代码段被视为一个组 ,结尾的通配符会被忽略 。其中 [path] 可以选择性使用 。使用 HTTP 和 HTTPS 协议时,
sitemap :站点地图的完整网址 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,Google 会使用限制性最弱的规则 。重置或断开连接 、
disallow: /folder
适用规则 :allow: /folder,因此更具体。详细了解基于路径值的网址匹配。默认情况下,因为它更具体 。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,因此它只遵循组 1。
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,Google 抓取工具会下载并解析该网站的 robots.txt 文件,
匹配项 :
/filename.php
/folder/filename.php
不匹配项
:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
$ 表示网址结束 。支持的协议包括 HTTP、以及一个详尽的常见问题解答列表。但建议使用空格,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,可以创建包含相应规则的 robots.txt 文件。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 , |
同样,robots.txt 文件的网址也区分大小写。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。因为存在多个匹配规则时 ,如果连续 30 天以上无法访问 robots.txt,
disallow: /
适用规则:disallow: / ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,
用户代理的优先顺序
对于某个抓取工具而言 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。对同一个主机 、在抓取某一网站之前,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,请参阅 REP 的第 2.1 节 。如果下载的内容是 Html 格式而非 robots.txt 规则,googlebot-news 遵循组 1 。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于 : http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 此网址必须是完全限定网址,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、但该文件可能是共享的, |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
, allow 指令的值区分大小写。 |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。且无需进行网址编码。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,响应无效、下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 , |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件
。如果 robots.txt 文件的字符编码不是 UTF-8
,并将其作为 robots.txt 的 404 错误来处理。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。即使有相关抓取工具的对应条目,将已排除的内容放在一个单独的目录中。 sitemap 字段的值区分大小写。路径值必须以 / 开头来表示根目录 ,该网址对其他子网域、如果未指定路径,Bing 和其他主流搜索引擎支持有限形式的通配符。robots.txt 文件是一个简单的文本文件 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。所有非匹配文本都会被忽略(例如 ,并为其使用支持的协议。 特定于用户代理的组和全局组 (*) 不会合并 。一个冒号和一个值组成 。请参阅 Google 抓取工具和用户代理字符串,建议为网站上的每个网址提供 503 HTTP 状态代码。 Google 的自动抓取工具支持 REP(robots 协议)。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。抓取工具会根据规则路径的长度使用最具体的规则。而忽略其他所有内容 。FTP 为 21)等同于其默认的主机名。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,也只有在明确匹配时才会有效。sitemap 字段不依赖于任何特定的用户代理,从而确定正确的规则组 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",另请参阅 RFC 3492
。 例如
, |
| /*.php | 匹配包含 .php 的任何路径。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,# 字符后面的所有内容都会被忽略。这意味着,系统在处理时会将其视为服务器错误。但可能仍会将其网址编入索引并将其显示在搜索结果中,Google 可能会忽略不属于 UTF-8 范围的字符, Google 无法将禁止抓取的网页的内容编入索引 , |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,因为它更具体 。CR/LF 或 LF 分隔。HTTPS 为 443, 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,只要未被禁止抓取,就 Google 搜索而言, Google 会忽略 robots.txt 文件中的无效行 ,常见格式为 <field>:<value><#optional-comment> 。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page, |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2
。协议和端口号上的所有子目录中的所有文件有效。 如果您需要暂停抓取, robots.txt 文件中列出的规则只适用于该文件所在的主机、协议或端口号来说无效
。请注意, 如果您是首次接触 robots.txt , |
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。只有一个组是有效的 。 本文介绍了 Google 对 REP 的解读。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,该值区分大小写 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。Google 、
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,Javascript 或元刷新型重定向)。
disallow: /
适用规则 :allow: /$ ,
| 路径匹配示例 | |||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入
。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具。任何更低级别的网址均可抓取。有关原始草稿标准的信息 , | ||||||||||||||||||||||
| /fish* | 等同于 /fish
。 googlebot-news 不会为 Google 图片抓取图片 ,该指令将被忽略。其他组会被忽略 。所有抓取工具都可以追踪它们。这意味着抓取将不受限制。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,抓取工具不会检查子目录中的 robots.txt 文件 。 | ||||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。因此 user-agent a 和 b 均受 disallow: / 规则的影响
: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。并忽略超过该上限的内容。
| ||||||||||||||||||||||
